Irgend wie beisse ich mir die Zähne an dem Thema aus.
kurz mal zusammengefasst was ich mir wĂĽnschen wĂĽrde.
Cisco 877 mit ADSLoPOTS an einem UPC Business Silber Anschluss wobei ich auf Fe0 und Fe1 gerne Access für mein LAN Hätte (NAT, 192.168.x.y, DHCP)
Fe2 und Fe3 sollen direkt access auf meine Public IPs bieten (/27er Netz)
Ich bekomme beides fĂĽr sich gesehen hin
NAT mit DHCP
- Code: Alles auswählen
sh runn
Building configuration...
Current configuration : 2958 bytes
!
! Last configuration change at 02:46:07 cet Sun Feb 5 2012 by Nooto
! NVRAM config last updated at 02:46:08 cet Sun Feb 5 2012 by Nooto
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname C877
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
no logging buffered
!
no aaa new-model
clock timezone cet 1
!
!
no ip source-route
!
!
no ip dhcp use vrf connected
no ip dhcp conflict logging
!
ip dhcp pool LAN
import all
network 192.168.1.0 255.255.255.0
domain-name supercarrier.at
dns-server 8.8.8.8 208.67.222.222
default-router 192.168.1.1
lease 0 2
!
!
ip cef
ip domain name supercarrier.at
ip name-server 195.58.160.194
ip name-server 195.58.161.122
ip name-server 8.8.8.8
ip name-server 208.67.222.222
no ipv6 cef
!
!
!
!
username Nooto privilege 15 secret 5 mypw
!
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface ATM0
no ip address
ip virtual-reassembly
atm vc-per-vp 64
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5snap
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
spanning-tree portfast
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface Vlan1
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
ip address negotiate
no ip redirects
ip mtu 1492
ip nat outside
no ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer remote-name UPC
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username user password 0 pw
ppp ipcp dns request
ppp ipcp mask request
ppp ipcp address accept
hold-queue 224 in
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
!
ip nat translation tcp-timeout 180
ip nat inside source list acl_nat interface Dialer0 overload
!
ip access-list extended acl_nat
deny ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.127.255
permit ip 192.168.1.0 0.0.0.255 any
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner motd ^
************************************************************************
* *
* THIS SYSTEM IS FOR THE USE OF AUTHORISED USER NOOTO ONLY! *
* *
* For unauthorized users all access is prohibited and protected by *
* the use of Baseball Bat force. *
* *
* Individuals using this system are subject to having all of their *
* activities on this system monitored, logged and checked by Nooto. *
* *
* *
* When you login to this host you automatically agree with the above *
* mentioned terms! And now, move along nothing to see here *
* *
************************************************************************
^C
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
privilege level 15
login local
transport input ssh
!
scheduler max-task-time 5000
ntp server 129.69.1.153
end
so das funktioniert auch wunderbar. NAT, Einwahl und DHCP funktionieren bestens.
Dann habe ich versucht eine simple @work config mit Public IPs hin zu bekommen
das schaute in ungefĂĽhr so aus:
- Code: Alles auswählen
conf t
username Nooto privilege 15 secret pw
hostname C877
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
logging buffered 15000
no ip domain lookup
banner motd ^
************************************************************************
* *
* THIS SYSTEM IS FOR THE USE OF AUTHORISED USER NOOTO ONLY! *
* *
* For unauthorized users all access is prohibited and protected by *
* the use of Baseball Bat force. *
* *
* Individuals using this system are subject to having all of their *
* activities on this system monitored, logged and checked by Nooto. *
* *
* *
* When you login to this host you automatically agree with the above *
* mentioned terms! And now, move along nothing to see here *
* *
************************************************************************
^C
clock timezone MET 1
clock summer-time MET-DST recurring last Sun Mar 2:00 last Sun Oct 2:00
ntp server 129.69.1.153
ip cef
interface ATM0
no shut
exit
interface ATM0.835 point-to-point
description ***PPPoE***
mtu 1492
pvc 8/35
encapsulation aal5snap
pppoe-client dial-pool-number 1
exit
exit
interface Dialer0
description WAN_PPPoE
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname user
ppp chap password pw
interface Vlan1
description LAN
ip address meine pub ip 255.255.255.224
ip tcp adjust-mss 1452
exit
ip route 0.0.0.0 0.0.0.0 Dialer0
dialer-list 1 protocol ip permit
line con 0
logging synchronous
login local
exit
line vty 0 4
logging synchronous
exec-timeout 0
login local
exit
funktioniert an sich auch. Router ist von extern erreichbar. ich kann vom Router weg pingen jedoch kann ich von keinem Angeschlossenen Host aus ins Internet (selbstverst. pub ip am Network Interface vergeben. Gateway kann ich jedoch pingen)
Die frage ist nun. Wo steckt der Fehler in meiner Pub IP cfg, Kann ich die beiden "verheiraten" und auf unterschiedliche Interfaces anwenden.
Bzgl. des Verheiratens habe ich bisher folgendes versucht
- Code: Alles auswählen
interface Dialer0
ip unnumbered vlan2
no ip redirects
ip mtu 1492
ip nat outside
no ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer remote-name UPC
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username user password 0 pw
ppp ipcp dns request
ppp ipcp mask request
ppp ipcp address accept
hold-queue 224 in
interface Vlan2
description Pub IPs
ip address my public IP GW 255.255.255.224
ip virtual-reassembly
ip tcp adjust-mss 1452
no shut
Das hat aber nur dazu gefĂĽhrt dass dann gar nichts mehr ging
last but not least bereitet mir der DHCP Server noch Kopfschmerzen.
Trotz definitv erfolgter IP Zuweisung durch den DHCP Server schauen die sh einträge so aus
- Code: Alles auswählen
C877#sh dhcp lease
C877#sh dhcp server
DHCP server: ANY (255.255.255.255)
Leases: 0
Offers: 0 Requests: 0 Acks : 0 Naks: 0
Declines: 0 Releases: 0 Query: 0 Bad: 0
C877#
kann mir das einer erklären?
Danke
Nooto